bixpark 0.0.2
bixpark: ^0.0.2 copied to clipboard

A new flutter plugin project.

0
likes
60/ 130
pub points
0%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://ceylon.app was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 35 API elements (8.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:bixpark/bixpark.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/bixpark_platform.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/bloc/bixpark_bloc.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
admob_flutter^0.3.10.3.41.0.1
firebase_analytics^5.0.115.0.168.3.4
firebase_crashlytics^0.1.3+30.1.4+12.2.4
firebase_dynamic_links^0.5.0+110.5.32.0.11
firebase_messaging^6.0.136.0.1610.0.9
firebase_remote_config^0.3.0+30.3.1+10.11.0+2
flutterflutter0.0.00.0.0
rxdart^0.24.00.24.10.27.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
firebase-7.3.39.0.2
firebase_analytics_platform_interface-1.1.02.0.1
firebase_analytics_web-0.1.10.3.0+1
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
platform-2.2.13.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^0.3.1` on admob_flutter does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions admob_flutter to update the constraint.

The constraint `^5.0.11` on firebase_analytics does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions firebase_analytics to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.