bird_cryptography 0.0.1+2
bird_cryptography: ^0.0.1+2 copied to clipboard

Platform agnostic implementation and interfaces for cryptographic primitives.

1
likes
75 / 110
pub points
43 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://www.github.com/modulovalue/bird_cryptography was unreachable.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/modulovalue/bird_cryptography/issues was unreachable.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 73 out of 283 API elements (25.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/util/block_mode.dart:169:28

    ╷
169 │   final List<int> result = List(length);
    │                            ^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/util/block_mode.dart

lib/src/systems/ethereum_keystore.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bird^0.0.20.0.3+50.0.3+5
collection^1.14.11.15.01.15.0
convert^2.0.02.1.13.0.0
crypto^2.0.2+12.1.53.0.1
meta^1.0.01.3.01.3.0
pointycastle^1.0.01.0.23.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
abstract_dart-1.0.21.0.2
async-2.5.02.5.0
charcode-1.2.01.2.0
dartz-0.9.20.9.2
decimal-0.3.51.0.0+1
matcher-0.12.100.12.10
path-1.8.01.8.0
pedantic-1.11.01.11.0
quiver-2.1.53.0.1
rational-0.3.81.0.0
stack_trace-1.10.01.10.0
statemachine-1.6.22.0.1
trie-1.0.21.0.2
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.0.0` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `^2.0.2+1` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

1
likes
75
pub points
43%
popularity

Publisher

modulovalue.com

Platform agnostic implementation and interfaces for cryptographic primitives.

Homepage
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bird, collection, convert, crypto, meta, pointycastle

More

Packages that depend on bird_cryptography