bcs 0.0.6 copy "bcs: ^0.0.6" to clipboard
bcs: ^0.0.6 copied to clipboard

Binary Canonical Serialization (BCS) in Dart.

1
likes
130/ 160
pub points
44%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

62 out of 154 API elements (40.3 %) have documentation comments.

Some symbols that are missing documentation: basex, basex.BaseXCodec, basex.BaseXCodec.BaseXCodec, basex.BaseXCodec.alphabet, basex.BaseXDecoder.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/base_x/base_x_codec.dart:1:1

  ╷
1 │ part of basex;
  │ ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/base_x/base_x_codec.dart

INFO: The part-of directive uses a library name.

lib/base_x/base_x_decoder.dart:1:1

  ╷
1 │ part of basex;
  │ ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/base_x/base_x_decoder.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
130
pub points
44%
popularity

Publisher

verified publishermofalabs.com

Binary Canonical Serialization (BCS) in Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on bcs