bazel_worker 1.1.0 copy "bazel_worker: ^1.1.0" to clipboard
bazel_worker: ^1.1.0 copied to clipboard

Protocol and utilities to implement or invoke persistent bazel workers.

4
likes
140/ 140
pub points
84%
popularity

We analyzed this package 33 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

175 out of 281 API elements (62.3 %) have documentation comments.

Some symbols that are missing documentation: bazel_worker, bazel_worker.AsyncWorkerConnection, bazel_worker.AsyncWorkerLoop.connection, bazel_worker.EXIT_CODE_BROKEN_PIPE, bazel_worker.EXIT_CODE_ERROR.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:bazel_worker/bazel_worker.dart that imports:
  • package:bazel_worker/src/worker/worker_connection.dart that imports:
  • package:bazel_worker/src/sync_message_grouper.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.5.0 2.11.0 2.11.0
protobuf ^3.0.0 3.1.0 3.1.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
fixnum - 1.1.0 1.1.0
meta - 1.12.0 1.12.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

4
likes
140
pub points
84%
popularity

Publisher

verified publishertools.dart.dev

Protocol and utilities to implement or invoke persistent bazel workers.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

async, protobuf

More

Packages that depend on bazel_worker