basic_settings 0.1.1
basic_settings: ^0.1.1 copied to clipboard

Model for individual settings based on a Hive box and MobX observables, and associated UI

1
likes
90 / 130
pub points
0 %
popularity

We analyzed this package on May 14, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 49 API elements (8.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_localizationsflutter0.0.00.0.0
flutter_mobx^1.1.0+21.1.0+22.0.0
hive^1.4.41.4.4+12.0.4
logging^0.11.40.11.41.0.1
meta^1.2.31.3.01.3.0
mobx^1.2.1+21.2.1+42.0.1
provider^4.3.24.3.35.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
intl-0.17.00.17.0
nested-1.0.01.0.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^1.1.0+2` on flutter_mobx does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_mobx to update the constraint.

The constraint `^1.4.4` on hive does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions hive to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

1
likes
90
pub points
0%
popularity

Publisher

inside.holvonix.com

Model for individual settings based on a Hive box and MobX observables, and associated UI

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

flutter, flutter_localizations, flutter_mobx, hive, logging, meta, mobx, provider

More

Packages that depend on basic_settings