baserouter 0.0.2+1 copy "baserouter: ^0.0.2+1" to clipboard
baserouter: ^0.0.2+1 copied to clipboard

A layered routing package and general mini-state carrier for flutter apps.

2
likes
120/ 140
pub points
0%
popularity

We analyzed this package 7 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

28 out of 82 API elements (34.1 %) have documentation comments.

Some symbols that are missing documentation: basecontainer, basecontainer.BaseContainerEntry, basecontainer.BaseContainerEntry.BaseContainerEntry, basecontainer.BaseContainerEntry.entry, basecontainerOptions.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/baseclass/basecontainerOptions.dart:59:28

   ╷
59 │     WidgetsBinding.instance!.addObserver(this);
   │                            ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/baseclass/basecontainerOptions.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/baseclass/basecontainerOptions.dart:65:28

   ╷
65 │     WidgetsBinding.instance!.removeObserver(this);
   │                            ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/baseclass/basecontainerOptions.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
provider ^6.0.0 6.1.2 6.1.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

2
likes
120
pub points
0%
popularity

Publisher

unverified uploader

A layered routing package and general mini-state carrier for flutter apps.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, provider

More

Packages that depend on baserouter