base32 1.1.2
base32: ^1.1.2 copied to clipboard

Base32 Encoder and Decoder for Dart, primarily used for One Time Password secrets.

6
likes
90 / 130
pub points
92 %
popularity

We analyzed this package on May 7, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 9 API elements (66.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/base32.dart:116:23

    ╷
116 │     List<int> bytes = List<int>();
    │                       ^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/base32.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert>=2.0.0 <3.0.02.1.13.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.0.0 <3.0.0` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=1.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

6
likes
90
pub points
92%
popularity

Publisher

yuli.dev

Base32 Encoder and Decoder for Dart, primarily used for One Time Password secrets.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE.txt)

Dependencies

convert

More

Packages that depend on base32