background_geolocation 0.0.1
background_geolocation: ^0.0.1 copied to clipboard

Flutter Android iOS

The most sophisticated background location-tracking & geofencing module with battery-conscious motion-detection intelligence for iOS and Android.

4
likes
75 / 110
pub points
18 %
popularity

We analyzed this package on Jan 18, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 3 links are insecure.

README.md:16:16

   ╷
16 │ <p>The <strong><a href="http://www.transistorsoft.com/shop/products/flutter-background-geolocation">Android module</a></strong> requires <a href="http://www.transistorsoft.com/shop/products/flutter-background-geolocation">purchasing a license</a>.  However, it <em>will</em> work for <strong>DEBUG</strong> builds.  It will <strong>not</strong> work with <strong>RELEASE</strong> builds <a href="http://www.transistorsoft.com/shop/products/flutter-background-geolocation">without purchasing a license</a>.</p>
   │                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 290 out of 379 API elements (76.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:background_geolocation/background_geolocation.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'List' is deprecated and shouldn't be used.

lib/background_geolocation.dart:138:51

    ╷
138 │   static List<_Subscription> _subscriptions = new List();
    │                                                   ^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/background_geolocation.dart

INFO: 'List' is deprecated and shouldn't be used.

lib/models/geofences_change_event.dart:22:19

   ╷
22 │     this.on = new List<Geofence>();
   │                   ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/models/geofences_change_event.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
background_fetch^0.1.00.1.20.6.0
device_info^0.3.00.3.01.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.0` on background_fetch does not support the latest published version `0.6.0`

pubspec.yaml:11:21

   ╷
11 │   background_fetch: ^0.1.0
   │                     ^^^^^^
   ╵
The constraint `^0.3.0` on device_info does not support the latest published version `1.0.0`

pubspec.yaml:10:16

   ╷
10 │   device_info: ^0.3.0
   │                ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

4
likes
75
pub points
18%
popularity

The most sophisticated background location-tracking & geofencing module with battery-conscious motion-detection intelligence for iOS and Android.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

chris@transistorsoft.com

License

unknown (LICENSE)

Dependencies

background_fetch, device_info, flutter

More

Packages that depend on background_geolocation