azblob 1.0.3

A trivial Azure Blob Storage client.

Usage #

A simple usage example:

import 'package:azblob/azblob.dart';

main() async {
  var storage = AzureStorage.parse('your connection string');
  await storage.putBlob('/yourcontainer/yourfile.txt',
    body: 'Hello, world.');
}

License #

ISC

1.0.3 #

  • Add example

1.0.2 #

  • Fix example

1.0.1 #

  • Fix pub suggestions

1.0.0 #

  • Initial version, created by Stagehand

example/example.dart

import 'package:azblob/azblob.dart';

main() async {
  var storage = AzureStorage.parse('your connection string');
  await storage.putBlob('/yourcontainer/yourfile.txt', body: 'Hello, world.');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  azblob: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:azblob/azblob.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Feb 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Maintenance issues and suggestions

Fix analysis_options.yaml.

The analyzer can't parse analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.5.0 <3.0.0
crypto ^2.1.4 2.1.4
http ^0.12.0+4 0.12.0+4
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
convert 2.1.1
http_parser 3.1.3
meta 1.1.8
path 1.6.4
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
effective_dart ^1.2.0
pedantic ^1.8.0 1.9.0
test ^1.6.0