aym_router 1.0.1

AYMRouter Dart libraries. A flutter routing generator that automatically generates routing tables when compiling. Need to use with aym_router_generator.

For more information, please refer to aym_router_generator.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aym_router: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aym_router/aym_router.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Feb 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health suggestions

Fix lib/src/com/aymtools/router/core.dart. (-1 points)

Analysis of lib/src/com/aymtools/router/core.dart reported 2 hints:

line 100 col 9: Use isNotEmpty instead of length

line 114 col 11: Use contains instead of indexOf

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and aym_router.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.5.0 <3.0.0
bean_factory ^1.0.0 1.0.1