bean_factory 1.2.2

Bean factory core Dart libraries. A pre-compiled class image containing the contents of the constructor, methods, and properties. Need to use with bean_factory_generator.

Related examples, please refer to flutter-aym-router use

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bean_factory: ^1.2.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bean_factory/bean_factory.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
6
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14

Health suggestions

Fix lib/src/com/aymtools/beanfactory/factory.dart. (-1.99 points)

Analysis of lib/src/com/aymtools/beanfactory/factory.dart reported 4 hints:

line 85 col 9: Use isNotEmpty instead of length

line 100 col 11: Use contains instead of indexOf

line 122 col 9: Use isNotEmpty instead of length

line 137 col 11: Use contains instead of indexOf

Fix lib/src/com/aymtools/beanfactory/core.dart. (-1 points)

Analysis of lib/src/com/aymtools/beanfactory/core.dart reported 2 hints:

line 31 col 14: 'otherImports' is deprecated and shouldn't be used. not uesd.

line 368 col 57: Don't explicitly initialize variables to null.

Format lib/src/com/aymtools/beanfactory/factory_initializer.dart.

Run dartfmt to format lib/src/com/aymtools/beanfactory/factory_initializer.dart.

Format lib/src/com/aymtools/beanfactory/type_adapter.dart.

Run dartfmt to format lib/src/com/aymtools/beanfactory/type_adapter.dart.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and bean_factory.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.5.0 <3.0.0