awsome_video_player 1.0.8+1
awsome_video_player: ^1.0.8+1 copied to clipboard

This is a flutter package of video player. it's a very simple and easy to use.

44
likes
85/ 130
pub points
84%
popularity

We analyzed this package 4 days ago, and awarded it 85 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 100 API elements (25.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:awsome_video_player/awsome_video_player.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^0.4.60.4.9+53.0.6
flutterflutter0.0.00.0.0
orientation^1.1.01.3.01.3.0
screen^0.0.50.0.50.0.5
video_player^0.10.8+10.10.12+52.2.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
connectivity_for_web-0.3.1+40.4.0+1
connectivity_macos-0.1.0+70.2.1+2
connectivity_platform_interface-1.0.62.0.1
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
plugin_platform_interface-1.0.32.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
video_player_platform_interface-2.2.04.2.0
video_player_web-0.1.4+12.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.6` on connectivity does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions connectivity to update the constraint.

The constraint `^0.10.8+1` on video_player does not support the stable version `0.11.0`.

Try running dart pub upgrade --major-versions video_player to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

44
likes
85
pub points
84%
popularity

This is a flutter package of video player. it's a very simple and easy to use.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

connectivity, flutter, orientation, screen, video_player

More

Packages that depend on awsome_video_player