aws_auth 2.0.1 copy "aws_auth: ^2.0.1" to clipboard
aws_auth: ^2.0.1 copied to clipboard

Low-level library for signing AWS API requests.

8
likes
100/ 140
pub points
59%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

36 out of 36 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The '?' is unnecessary because 'dynamic' is nullable without it.

lib/src/request.dart:108:12

    ╷
108 │     dynamic? body,
    │            ^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/request.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
convert ^3.0.0 3.1.1 3.1.1
crypto ^3.0.0 3.0.3 3.0.3
intl ^0.17.0 0.17.0 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
path - 1.9.0 1.9.0
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

8
likes
100
pub points
59%
popularity

Publisher

verified publisherbacic.dev

Low-level library for signing AWS API requests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, convert, crypto, intl

More

Packages that depend on aws_auth