aws_appsync 0.1.0
aws_appsync: ^0.1.0 copied to clipboard

A new Flutter package project.

4
likes
80/ 130
pub points
54%
popularity

We analyzed this package on Sep 28, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 24 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:aws_appsync/aws_appsync.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.1.32.1.53.0.1
flutterflutter0.0.00.0.0
http^0.12.10.12.20.13.3
logging^0.11.40.11.41.0.2
path_provider^1.6.71.6.282.0.5
sembast^2.4.32.4.10+43.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
http_parser-3.1.44.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.0
path_provider_macos-0.0.4+82.0.2
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
pedantic-1.11.11.11.1
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.1
process-4.2.34.2.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.92.2.9
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^2.1.3` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^0.12.1` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.