aws_apigateway_api 0.0.1 icon indicating copy to clipboard operation
aws_apigateway_api: ^0.0.1 copied to clipboard

AWS API client for Amazon API Gateway (generated from SDK API specification).

0
likes
95/ 130
pub points
28%
popularity

We analyzed this package 32 days ago, and awarded it 95 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
15 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 456 out of 733 API elements (62.2 %) have documentation comments.
icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 2 possible platforms (native, js)

icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
shared_aws_api^0.2.20.2.41.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
http-0.12.20.13.4
http_parser-3.1.44.0.0
intl-0.16.10.17.0
json_annotation-3.1.14.4.0
meta-1.7.01.7.0
path-1.8.11.8.1
pedantic-1.11.11.11.1
petitparser-3.1.04.4.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
xml-4.5.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.2` on shared_aws_api does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions shared_aws_api to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.1.

0
likes
95
pub points
28%
popularity

Publisher

shield icon for verified publishersaws-dart.agilord.com

AWS API client for Amazon API Gateway (generated from SDK API specification).

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

shared_aws_api

More

Packages that depend on aws_apigateway_api