awesome_theme 0.0.1+2

Flutter Android iOS web

A new Flutter package project.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Sep 30, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 42 API elements (9.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:awesome_theme/awesome_theme.dart that imports:
  • package:awesome_theme/src/provider.dart that imports:
  • package:awesome_theme/src/bloc.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:awesome_theme/awesome_theme.dart that imports:
  • package:awesome_theme/src/provider.dart that imports:
  • package:awesome_theme/src/bloc.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:awesome_theme/awesome_theme.dart that imports:
  • package:awesome_theme/src/provider.dart that imports:
  • package:awesome_theme/src/bloc.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform Linux

Because:

  • package:awesome_theme/awesome_theme.dart that imports:
  • package:awesome_theme/src/provider.dart that imports:
  • package:awesome_theme/src/bloc.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform macOS

Because:

  • package:awesome_theme/awesome_theme.dart that imports:
  • package:awesome_theme/src/provider.dart that imports:
  • package:awesome_theme/src/bloc.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform Web

Because:

  • package:awesome_theme/awesome_theme.dart that imports:
  • package:awesome_theme/src/provider.dart that imports:
  • package:awesome_theme/src/bloc.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^0.11.20.11.26.0.3
flutterflutter0.0.00.0.0
flutter_bloc^0.9.10.9.16.0.5
flutter_redux^0.5.30.5.40.6.0
http^0.12.0+10.12.20.12.2
shared_preferences^0.5.1+20.5.120.5.12
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.43.1.4
intl-0.16.10.16.1
meta-1.1.81.2.3
path-1.7.01.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
pedantic-1.9.01.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
redux-3.0.04.0.0+3
rxdart-0.21.00.24.1
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+10.0.1+1
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8
win32-1.7.31.7.3
xdg_directories-0.1.00.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.11.2` on bloc does not support the latest published version `6.0.3`

pubspec.yaml:16:9

   ╷
16 │   bloc: ^0.11.2
   │         ^^^^^^^
   ╵
The constraint `^0.9.1` on flutter_bloc does not support the latest published version `6.0.5`

pubspec.yaml:17:17

   ╷
17 │   flutter_bloc: ^0.9.1
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs