awesome_loader 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 85

awesome_loader #

A Dart plugin for using some Awesome Loaders in your application.

Image

Usage #

To use this plugin, add awesome_loader as a dependency in your pubspec.yaml file.

It contains 4 animated loaders namely:

  • AwesomeLoader1
  • AwesomeLoader2
  • AwesomeLoader3
  • AwesomeLoader4

Example #

Below is the example of using AwesomeLoader

import 'package:flutter/material.dart';
import 'package:awesome_loader/awesome_loader.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter Demo',
      home: Scaffold(
        body: Center(
          child: AwesomeLoader(
          ),
        ),
      ),
    );
  }
}

AwesomeLoader() accepts 2 optional parameters:

  • loaderType : Pass this to change loader type.
  • color : Pass this to change Loader Color.

Value of loaderType can be:

  • AwesomeLoader.AwesomeLoader1
  • AwesomeLoader.AwesomeLoader2
  • AwesomeLoader.AwesomeLoader3
  • AwesomeLoader.AwesomeLoader4
import 'package:flutter/material.dart';
import 'package:awesome_loader/awesome_loader.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter Demo',
      home: Scaffold(
        body: Center(
          child: AwesomeLoader(
            loaderType: AwesomeLoader.AwesomeLoader2,
            color: Colors.blue,
          ),
        ),
      ),
    );
  }
}

[0.0.2] - 2019-03-13

  • Added one more loader

[0.0.2] - 2019-03-02

  • Contains 3 Awesome Loader.
  • Easy to use.
  • Can customize their Colors.
  • Fixed Few Issues

[0.0.1] - 2019-03-01

  • Initial Release

example/main.dart

import 'package:flutter/material.dart';
import 'package:awesome_loader/awesome_loader.dart';

class main extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: Text("Awesome Loader"),
        ),
        body: Container(
          color: Colors.indigoAccent,
          child: Column(
            children: <Widget>[
              AwesomeLoader(
                loaderType: AwesomeLoader.AwesomeLoader1,
                color: Colors.white,
              ),
              AwesomeLoader(
                loaderType: AwesomeLoader.AwesomeLoader2,
                color: Colors.white,
              ),
              AwesomeLoader(
                loaderType: AwesomeLoader.AwesomeLoader3,
                color: Colors.white,
              ),
              AwesomeLoader(
                loaderType: AwesomeLoader.AwesomeLoader4,
                color: Colors.white,
              ),
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  awesome_loader: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:awesome_loader/awesome_loader.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
74
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test