awareframework_openweather 0.0.3

Flutter Android iOS

A new flutter plugin project.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 24 API elements (37.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:awareframework_openweather/awareframework_openweather.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:awareframework_openweather/awareframework_openweather.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:awareframework_openweather/awareframework_openweather.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:awareframework_openweather/awareframework_openweather.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: OpenWeatherCard.data

lib/awareframework_openweather.dart:47:7

   ╷
47 │ class OpenWeatherCard extends StatefulWidget {
   │       ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/awareframework_openweather.dart

lib/awareframework_openweather.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
awareframework_core^0.0.90.0.110.1.1
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
charts_common-0.5.00.9.0
charts_flutter-0.5.00.9.0
collection-1.14.131.14.13
intl-0.15.80.16.1
logging-0.11.40.11.4
meta-1.1.81.2.3
path-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.9` on awareframework_core does not support the latest published version `0.1.1`

pubspec.yaml:13:24

   ╷
13 │   awareframework_core: ^0.0.9
   │                        ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

A new flutter plugin project.

Homepage

Documentation

API reference

Uploader

yukinishi55@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

awareframework_core, flutter

More

Packages that depend on awareframework_openweather