avatar_glow 1.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 96

Avatar Glow GitHub stars Twitter Follow GitHub last commit Website shields.ioOpen Source Love

This Flutter package provides a Avatar Glow Widget with cool background glowing animation.

💻 Installation #

In the dependencies: section of your pubspec.yaml, add the following line:

Version

dependencies:
  avatar_glow: <latest version>

❔ Usage #

Import this class #

import 'package:avatar_glow/avatar_glow.dart';

Usage is simple. Avatar Glow is a widget offering different customizable optional parameters with child displayed at its center. #

PieChart

- Simple Implementation #

AvatarGlow(
    endRadius: 90.0,   //required
    child: Material(   //required
      elevation: 8.0,
      shape: CircleBorder(),
      child: CircleAvatar(
        backgroundColor:Colors.grey[100] ,
        child: Image.asset('assets/images/flutter.png',height: 60,),
        radius: 40.0,
        shape: BoxShape.circle
      ),
    ),
  )

- Full Implementation #

AvatarGlow(
    startDelay: Duration(milliseconds: 1000),
    glowColor: Colors.blue,
    endRadius: 90.0,
    duration: Duration(milliseconds: 2000),
    repeat: true,
    showTwoGlows: true,
    repeatPauseDuration: Duration(milliseconds: 100),
    child: Material(
      elevation: 8.0,
      shape: CircleBorder(),
      child: CircleAvatar(
        backgroundColor:Colors.grey[100] ,
        child: Image.asset('assets/images/flutter.png',height: 60,),
        radius: 40.0,
        shape: BoxShape.circle
      ),
    ),
    shape: BoxShape.circle,
    animate: true,
    curve: Curves.fastOutSlowIn,
  )

⭐ My Flutter Packages #

  • json_table GitHub stars Create Flutter Json Table from json map directly.
  • pie_chart GitHub stars Flutter Pie Chart with cool animation.
  • search_widget GitHub stars Flutter Search Widget for selecting an option from list.
  • animating_location_pin GitHub stars Flutter Animating Location Pin Widget providing Animating Location Pin Widget which can be used while fetching device location.

⭐ My Flutter Apps #

👍 Contribution #

  1. Fork it
  2. Create your feature branch (git checkout -b my-new-feature)
  3. Commit your changes (git commit -m 'Add some feature')
  4. Push to the branch (git push origin my-new-feature)
  5. Create new Pull Request

[1.1.0]

Merged #

  • #6 Add 'animate', 'curve' option. Thanks @Nolence for PR. Thanks @Sahil for feedback.
  • Add macos support

[1.0.0]

Merged #

  • #5 Add option to change shape of widget. Thanks @gildurao

[0.2.0]

Merged #

  • #2 Fixes exception when using widget inside scroll widget. Fixed missing repeat parameter usage. Thanks @Sahil

Added #

  • Delay in starting animation 'startDelay'

[0.1.0] - Initial Release

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  avatar_glow: ^1.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:avatar_glow/avatar_glow.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
92
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
96
Learn more about scoring.

We analyzed this package on Nov 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test