avahi 0.1.0 copy "avahi: ^0.1.0" to clipboard
avahi: ^0.1.0 copied to clipboard

PlatformLinux

Provides a client to connect to Avahi - the service that implements mDNS/DNS-SD on Linux.

4
likes
140/ 140
pub points
17%
popularity

We analyzed this package 5 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

14 out of 15 API elements (93.3 %) have documentation comments.

Some symbols that are missing documentation: avahi.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Linux

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:avahi/avahi.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:avahi/avahi.dart that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • package:avahi/avahi.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:avahi/avahi.dart that declares support for platforms: Linux.
Package does not support platform `Web`.

Because:

  • package:avahi/avahi.dart that declares support for platforms: Linux.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dbus ^0.7.0 0.7.10 0.7.10
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
meta - 1.14.0 1.14.0
petitparser - 6.0.2 6.0.2
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

4
likes
140
pub points
17%
popularity

Publisher

verified publishercanonical.com

Provides a client to connect to Avahi - the service that implements mDNS/DNS-SD on Linux.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MPL-2.0 (LICENSE)

Dependencies

dbus

More

Packages that depend on avahi