autotrie 2.0.0 copy "autotrie: ^2.0.0" to clipboard
autotrie: ^2.0.0 copied to clipboard

A auto-completion engine for Dart/Flutter, based around an optimized Trie implementation.

41
likes
150/ 160
pub points
76%
popularity

We analyzed this package 3 days ago, and awarded it 150 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/AKushWarrior/autotrie/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

21 out of 40 API elements (52.5 %) have documentation comments.

Some symbols that are missing documentation: autotrie.AutoComplete.AutoComplete.fromFile, autotrie.AutoCompleteBox, autotrie.SortEngine, autotrie.SortEngine.scoreFunc, autotrie.SortValue.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:autotrie/autotrie.dart that imports:
  • package:autotrie/src/autotrie_base.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Missing a corresponding override of 'hashCode'.

lib/src/datatree/tree.dart:154:17

    ╷
154 │   bool operator ==(covariant TrieNode other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/datatree/tree.dart

lib/autotrie.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
hive ^2.0.0 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0
crypto - 3.0.3 3.0.3
meta - 1.15.0 1.15.0
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

41
likes
150
pub points
76%
popularity

Publisher

verified publisherkishoredev.live

A auto-completion engine for Dart/Flutter, based around an optimized Trie implementation.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MPL-2.0 (license)

Dependencies

hive

More

Packages that depend on autotrie