auto_route_generator 8.1.0 copy "auto_route_generator: ^8.1.0" to clipboard
auto_route_generator: ^8.1.0 copied to clipboard

AutoRoute is a declarative routing solution, where everything needed for navigation is automatically generated for you.

130
likes
40/ 160
pub points
97%
popularity

We analyzed this package 17 hours ago, and awarded it 40 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
Because auto_route_generator depends on auto_route >=4.1.0 which requires the Flutter SDK, version solving failed.
Flutter users should use `flutter pub` instead of `dart pub`.
failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because auto_route_generator depends on auto_route >=4.1.0 which requires the Flutter SDK, version solving failed.

Flutter users should use `flutter pub` instead of `dart pub`.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

dart pub downgrade failed with:

OUT:
Resolving dependencies...
ERR:
Because auto_route_generator depends on auto_route >=4.1.0 which requires the Flutter SDK, version solving failed.

Flutter users should use `flutter pub` instead of `dart pub`.

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

130
likes
40
pub points
97%
popularity

Publisher

verified publishercodeness.ly

AutoRoute is a declarative routing solution, where everything needed for navigation is automatically generated for you.

Repository (GitHub)
View/report issues

License

MIT (license)

Dependencies

analyzer, args, auto_route, build, build_runner, code_builder, dart_style, glob, package_config, path, source_gen, xml

More

Packages that depend on auto_route_generator