auto_factory 3.0.0 copy "auto_factory: ^3.0.0" to clipboard
auto_factory: ^3.0.0 copied to clipboard

Automatically generate code for creating objects and their dependecies through factory classes

0
likes
130/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 2 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: auto_factory.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:auto_factory/auto_factory.dart that imports:
  • package:auto_factory/src/entry_point.dart that imports:
  • package:auto_factory/src/generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:auto_factory/auto_factory.dart that imports:
  • package:auto_factory/src/entry_point.dart that imports:
  • package:auto_factory/src/generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:auto_factory/auto_factory.dart that imports:
  • package:auto_factory/src/entry_point.dart that imports:
  • package:auto_factory/src/generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^5.12.0 5.13.0 6.4.1
auto_factory_annotation ^3.0.0 3.0.1 3.0.1
build ^2.0.0 2.4.1 2.4.1
path ^1.8.0 1.9.0 1.9.0
source_gen ^1.0.0 1.5.0 1.5.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 67.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.2 2.3.6
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
logging - 1.2.0 1.2.0
meta - 1.14.0 1.14.0
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.12.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

0
likes
130
pub points
0%
popularity

Publisher

verified publishermsiviero.dev

Automatically generate code for creating objects and their dependecies through factory classes

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, auto_factory_annotation, build, path, source_gen

More

Packages that depend on auto_factory