autility 1.0.4
autility: ^1.0.4 copied to clipboard

Flutter Android iOS macOS web

A collection of commonly used tools for developers,eg timer, network, shared preferences.

1
likes
90 / 110
pub points
4 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 87 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:autility/autility.dart that imports:
  • package:autility/utility/sp.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^0.4.90.4.9+53.0.0
convert^2.1.12.1.13.0.0
crypto^2.1.42.1.53.0.0
flutterflutter0.0.00.0.0
shared_preferences^0.5.30.5.12+42.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
connectivity_for_web-0.3.1+40.3.1+4
connectivity_macos-0.1.0+70.2.0
connectivity_platform_interface-1.0.62.0.0
ffi-0.1.31.0.0
file-5.2.16.1.0
flutter_web_plugins-0.0.00.0.0
intl-0.16.10.17.0
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_platform_interface-1.0.42.0.0
path_provider_windows-0.0.4+32.0.0
platform-2.2.13.0.0
plugin_platform_interface-1.0.32.0.0
process-3.0.134.1.0
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0
win32-1.7.4+12.0.0
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.4.9` on connectivity does not support the latest published version `3.0.0`

pubspec.yaml:12:17

   ╷
12 │   connectivity: ^0.4.9
   │                 ^^^^^^
   ╵
The constraint `^2.1.1` on convert does not support the latest published version `3.0.0`

pubspec.yaml:14:12

   ╷
14 │   convert: ^2.1.1
   │            ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

1
likes
90
pub points
4%
popularity

Publisher

adeveloper.tech

A collection of commonly used tools for developers,eg timer, network, shared preferences.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

connectivity, convert, crypto, flutter, shared_preferences

More

Packages that depend on autility