authenticator 0.1.2
authenticator: ^0.1.2 copied to clipboard

Flutter Android iOS

Firebase authentication package that includes mocked platform channels to facilitate unit testing with flutter test.

2
likes
90 / 110
pub points
41 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 49 out of 73 API elements (67.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:authenticator/authenticator.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_auth^0.14.0+50.14.0+91.0.0
flutterflutter0.0.00.0.0
flutter_facebook_login^3.0.03.0.03.0.0
google_sign_in^4.0.74.5.95.0.0
provider^3.1.03.2.04.3.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
firebase-7.3.39.0.0
firebase_core-0.4.51.0.0
firebase_core_platform_interface-1.0.44.0.0
firebase_core_web-0.1.1+21.0.0
flutter_web_plugins-0.0.00.0.0
google_sign_in_platform_interface-1.1.22.0.0
google_sign_in_web-0.9.20.10.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
js-0.6.20.6.3
matcher-0.12.90.12.10
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
pedantic-1.9.21.10.0
plugin_platform_interface-1.0.32.0.0
quiver-2.1.53.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.14.0+5` on firebase_auth does not support the latest published version `1.0.0`

pubspec.yaml:15:18

   ╷
15 │   firebase_auth: ^0.14.0+5
   │                  ^^^^^^^^^
   ╵
The constraint `^4.0.7` on google_sign_in does not support the latest published version `5.0.0`

pubspec.yaml:16:19

   ╷
16 │   google_sign_in: ^4.0.7
   │                   ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

2
likes
90
pub points
41%
popularity

Publisher

playscale.io

Firebase authentication package that includes mocked platform channels to facilitate unit testing with flutter test.

Repository (GitLab)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

firebase_auth, flutter, flutter_facebook_login, google_sign_in, provider

More

Packages that depend on authenticator