auth 7.3.2
auth: ^7.3.2 copied to clipboard

Flutter Android iOS

Authorization Library Package to log into Google, Facebook, or by Username and Password.

35
likes
100 / 110
pub points
78 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 50 out of 97 API elements (51.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:auth/auth.dart that imports:
  • package:auth/src/auth.dart that imports:
  • package:flutter_twitter/flutter_twitter.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_auth>=0.20.0 <1.0.00.20.11.0.0
firebase_core>=0.7.0 <1.0.00.7.01.0.0
flutterflutter0.0.00.0.0
flutter_login_facebook>=0.4.2 <1.0.00.5.00.5.0
flutter_twitter^1.0.01.1.31.1.3
google_sign_in^4.0.04.5.95.0.0
google_sign_in_platform_interface^1.0.01.1.22.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
firebase_auth_platform_interface-3.1.04.0.0
firebase_auth_web-0.3.31.0.0
firebase_core_platform_interface-3.0.14.0.0
firebase_core_web-0.2.1+31.0.0
flutter_web_plugins-0.0.00.0.0
google_sign_in_web-0.9.20.10.0
http_parser-3.1.44.0.0
intl-0.16.10.17.0
js-0.6.20.6.3
list_ext-0.2.00.2.0
matcher-0.12.90.12.10
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
plugin_platform_interface-1.0.32.0.0
quiver-2.1.53.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `>=0.20.0 <1.0.0` on firebase_auth does not support the stable version `1.0.0`, that was published 4 days ago.

When firebase_auth is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

The constraint `>=0.7.0 <1.0.0` on firebase_core does not support the stable version `1.0.0`, that was published 4 days ago.

When firebase_core is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

35
likes
100
pub points
78%
popularity

Publisher

andrioussolutions.com

Authorization Library Package to log into Google, Facebook, or by Username and Password.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 3.0 (LICENSE)

Dependencies

firebase_auth, firebase_core, flutter, flutter_login_facebook, flutter_twitter, google_sign_in, google_sign_in_platform_interface

More

Packages that depend on auth