audioplayers_web 5.0.0 copy "audioplayers_web: ^5.0.0" to clipboard
audioplayers_web: ^5.0.0 copied to clipboard

Platformweb

Web implementation of audioplayers, a Flutter plugin to play multiple audio files simultaneously

12
likes
150/ 160
pub points
91%
popularity

We analyzed this package 19 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

17 out of 59 API elements (28.8 %) have documentation comments.

Some symbols that are missing documentation: audioplayers_web, audioplayers_web.AudioplayersPlugin, audioplayers_web.AudioplayersPlugin.AudioplayersPlugin, audioplayers_web.WebAudioplayersPlatform, audioplayers_web.WebAudioplayersPlatform.WebAudioplayersPlatform.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:audioplayers_web/audioplayers_web.dart that declares support for platforms: Web.
Package does not support platform `iOS`.

Because:

  • package:audioplayers_web/audioplayers_web.dart that declares support for platforms: Web.
Package does not support platform `Windows`.

Because:

  • package:audioplayers_web/audioplayers_web.dart that declares support for platforms: Web.
Package does not support platform `Linux`.

Because:

  • package:audioplayers_web/audioplayers_web.dart that declares support for platforms: Web.
Package does not support platform `macOS`.

Because:

  • package:audioplayers_web/audioplayers_web.dart that declares support for platforms: Web.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
audioplayers_platform_interface ^7.0.0 7.0.0 7.0.0
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
web ^0.5.1 0.5.1 1.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.1` on web does not support the stable version `1.0.0`, that was published 2 days ago.

When web is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions web to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

12
likes
150
pub points
91%
popularity

Publisher

verified publisherblue-fire.xyz

Web implementation of audioplayers, a Flutter plugin to play multiple audio files simultaneously

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

audioplayers_platform_interface, flutter, flutter_web_plugins, web

More

Packages that depend on audioplayers_web