audio_visualizer 0.1.1
audio_visualizer: ^0.1.1 copied to clipboard

Pure dart audio visualizer for android and ios

19
likes
60/ 130
pub points
81%
popularity

We analyzed this package 4 days ago, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2021-12-03T06:56:35.441088] Starting...
Documenting audio_visualizer...
Initialized dartdoc with 405 libraries in 89.7 seconds
Generating docs for library audio_visualizer from package:audio_visualizer/audio_visualizer.dart...
Generating docs for library line_bar_visualizer from package:audio_visualizer/visualizers/line_bar_visualizer.dart...
Generating docs for library visualizer from package:audio_visualizer/visualizers/visualizer.dart...
Generating docs for library bar_visualizer from package:audio_visualizer/visualizers/bar_visualizer.dart...
Generating docs for library multi_wave_visualizer from package:audio_visualizer/visualizers/multi_wave_visualizer.dart...
Generating docs for library circular_bar_visualizer from package:audio_visualizer/visualizers/circular_bar_visualizer.dart...
Generating docs for library circular_line_visualizer from package:audio_visualizer/visualizers/circular_line_visualizer.dart...
Generating docs for library line_visualizer from package:audio_visualizer/visualizers/line_visualizer.dart...
Generating docs for library audio_visualizer from package:audio_visualizer/fft.dart...
Documented 9 public libraries in 1.1 seconds

stderr:   warning: audio_visualizer has no library level documentation comments
    from audio_visualizer: (file:///tmp/pub-dartlang-dartdocVMJQMD/pkg/lib/fft.dart:1:9)
  error: failed to write file at: audio_visualizer/audio_visualizer-library.html
    for symbol audio_visualizer: (file:///tmp/pub-dartlang-dartdocVMJQMD/pkg/lib/fft.dart:1:9)
    conflicting with file already generated by audio_visualizer: (file:///tmp/pub-dartlang-dartdocVMJQMD/pkg/lib/audio_visualizer.dart:1:1)
            Dartdoc generates a path and filename to write to for each symbol.
            audio_visualizer conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
Found 1 warning and 1 error.
Unhandled exception:
encountered 1 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:241:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:32:19)
<asynchronous suspension>


Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:audio_visualizer/audio_visualizer.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/fft.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/visualizers/bar_visualizer.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
complex^0.6.10.6.10.7.2
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.1` on complex does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions complex to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

19
likes
60
pub points
81%
popularity

Pure dart audio visualizer for android and ios

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

complex, flutter

More

Packages that depend on audio_visualizer