audio_streamer 4.1.1 copy "audio_streamer: ^4.1.1" to clipboard
audio_streamer: ^4.1.1 copied to clipboard

Streaming of Pulse-code modulation (PCM) audio from Android and iOS

31
likes
140/ 140
pub points
85%
popularity

We analyzed this package 6 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5 out of 9 API elements (55.6 %) have documentation comments.

Some symbols that are missing documentation: audio_streamer, audio_streamer.AudioStreamer.DEFAULT_SAMPLING_RATE, audio_streamer.EVENT_CHANNEL_NAME, audio_streamer.METHOD_CHANNEL_NAME.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:audio_streamer/audio_streamer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:audio_streamer/audio_streamer.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:audio_streamer/audio_streamer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:audio_streamer/audio_streamer.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
permission_handler ^11.0.0 11.3.0 11.3.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
permission_handler_android - 12.0.5 12.0.5
permission_handler_apple - 9.4.0 9.4.0
permission_handler_html - 0.1.1 0.1.1
permission_handler_platform_interface - 4.2.0 4.2.0
permission_handler_windows - 0.2.1 0.2.1
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

31
likes
140
pub points
85%
popularity

Publisher

verified publishercachet.dk

Streaming of Pulse-code modulation (PCM) audio from Android and iOS

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, permission_handler

More

Packages that depend on audio_streamer