athena_postgres 1.0.13 copy "athena_postgres: ^1.0.13" to clipboard
athena_postgres: ^1.0.13 copied to clipboard

Dart PostgreSQL query builder, expressive and user-friendly API to build and manage SQL queries in your Dart projects.

0
likes
150/ 160
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

80 out of 349 API elements (22.9 %) have documentation comments.

Some symbols that are missing documentation: athena_postgres.AlterBuilder, athena_postgres.AlterBuilder.AlterBuilder, athena_postgres.AlterBuilder.driver, athena_postgres.AlterBuilder.table, athena_postgres.AlterTableBuilder.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:athena_postgres/athena_postgres.dart that imports:
  • package:athena_sql/athena_sql.dart that imports:
  • package:athena_utils/athena_utils.dart that imports:
  • package:athena_utils/src/files_service.dart that imports:
  • package:file/memory.dart that imports:
  • package:file/src/backends/memory.dart that imports:
  • package:file/src/backends/memory/style.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
athena_sql ^1.1.8 1.1.8 1.1.8
path ^1.8.3 1.9.0 1.9.0
postgres ^2.6.1 2.6.4 3.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
athena_utils - 1.0.4 1.0.4
buffer - 1.2.3 1.2.3
charcode - 1.3.1 1.3.1
collection - 1.19.0 1.19.0
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
meta - 1.15.0 1.15.0
pool - 1.5.1 1.5.1
sasl_scram - 0.1.1 0.1.1
saslprep - 1.0.3 1.0.3
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
unorm_dart - 0.3.0 0.3.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.6.1` on postgres does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions postgres to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

0
likes
150
pub points
0%
popularity

Publisher

verified publisherathena-sql.dev

Dart PostgreSQL query builder, expressive and user-friendly API to build and manage SQL queries in your Dart projects.

Homepage
Repository (GitHub)
View/report issues

Topics

#sql #postgres

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

athena_sql, path, postgres

More

Packages that depend on athena_postgres