atauth_flutter_plugin 0.0.7
atauth_flutter_plugin: ^0.0.7 copied to clipboard

Flutter Android iOS

阿里云号码认证服务flutter插件 Alibaba Cloud Phone Number Verification Service (https://help.aliyun.com/product/75010.html)

2
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 32 API elements (21.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:atauth_flutter_plugin/aliyun_number_auth.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/aliyun_number_auth.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/atauth_flutter_plugin.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

2
likes
70
pub points
0%
popularity

阿里云号码认证服务flutter插件 Alibaba Cloud Phone Number Verification Service (https://help.aliyun.com/product/75010.html)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ningjiansen@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on atauth_flutter_plugin