at_app 1.1.0-rc+3 icon indicating copy to clipboard operation
at_app: ^1.1.0-rc+3 copied to clipboard

A command line tool to help developers build an @ platform application.

7
likes
100/ 120
pub points
15%
popularity

We analyzed this package 7 days ago, and awarded it 100 pub points (of a possible 120):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 10icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/example.md
icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:at_app/at_app.dart that imports:
  • package:at_app/src/command_runner.dart that imports:
  • package:at_app/src/commands/create.dart that imports:
  • package:at_app/src/commands/create_base.dart that imports:
  • package:at_app/src/util/cli/flutter.dart that imports:
  • package:at_app/src/util/cli/cli_base.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/commands/create.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.2.02.3.02.3.0
io^1.0.31.0.31.0.3
logger^1.0.01.1.01.1.0
path^1.8.01.8.11.8.1
pub_cache^0.3.10.3.10.3.1
pub_semver^2.0.02.1.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
meta-1.7.01.7.0
source_span-1.8.21.8.2
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.15.1.

7
likes
100
pub points
15%
popularity

Publisher

shield icon for verified publishersatsign.org

A command line tool to help developers build an @ platform application.

Homepage
Repository (GitHub)
View/report issues

License

BSD-3-Clause (LICENSE)

Dependencies

args, io, logger, path, pub_cache, pub_semver

More

Packages that depend on at_app