asymmetric_crypto_primitives 0.5.0 copy "asymmetric_crypto_primitives: ^0.5.0" to clipboard
asymmetric_crypto_primitives: ^0.5.0 copied to clipboard

Flutter plugin for signing and managing keys on different devices.

0
likes
150/ 160
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: EUPL-1.2.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

43 out of 54 API elements (79.6 %) have documentation comments.

Some symbols that are missing documentation: asymmetric_crypto_primitives, asymmetric_crypto_primitives.AsymmetricCryptoPrimitives, asymmetric_crypto_primitives.AsymmetricCryptoPrimitives.AsymmetricCryptoPrimitives, ed25519_signer, ed25519_signer.Ed25519Signer.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:asymmetric_crypto_primitives/asymmetric_crypto_primitives.dart that declares support for platforms: Android, iOS, Windows, macOS.
Package does not support platform `Web`.

Because:

  • package:asymmetric_crypto_primitives/asymmetric_crypto_primitives.dart that declares support for platforms: Android, iOS, Windows, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
local_auth ^2.1.6 2.2.0 2.2.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
uuid ^3.0.6 3.0.7 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
intl - 0.19.0 0.19.0
local_auth_android - 1.0.39 1.0.39
local_auth_darwin - 1.3.1 1.3.1
local_auth_platform_interface - 1.0.10 1.0.10
local_auth_windows - 1.0.10 1.0.10
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.6` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.5, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

0
likes
150
pub points
0%
popularity

Publisher

verified publisherhumancolossus.org

Flutter plugin for signing and managing keys on different devices.

Repository (GitHub)
View/report issues

Documentation

API reference

License

EUPL-1.2 (LICENSE)

Dependencies

flutter, local_auth, plugin_platform_interface, uuid

More

Packages that depend on asymmetric_crypto_primitives