asn1lib 0.4.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 43

An ASN.1 Parser for Dart.

Encodes & decodes ASN1 using BER encoding.

There is just enough implementation here to get an LDAP client library working.

Sample

 var s = new ASN1Sequence();
s.add( new ASN1Integer(23));
s.add( new ASN1OctetString('This is a test'));
s.add( new ASN1Boolean(true));

// GET the BER Stream
var bytes = s.encodedBytes;

// decode
var p = new ASN1Parser(bytes);
var s2 = p.nextObject();
// s2 is a sequence...

Changes #

Remove obsolete crypto dependency in tests.

Added PrintableString and UTC Time elements

Changes to support RSA Private key : PEM file

Add import "package:bignum/bignum.dart"; in asn1lib.dart

Add ASN1ObjectIdentifier class

Add OBJECT_IDENTIFIER in asn1constants.dart

Modify ASN1Parser._doPrimitive to take OBJECT_IDENTIFIER and NULL_TYPE into account

Modify ASN1Null add contructor ASN1Null.fromBytes

Modify ASN1Integer to support BigInteger

Modify asn1element_test.dart to test BigInteger case, and rsa private key test

Add test/resource folder to store rsa key for testing

Changes to support RSA public key : PEM file

Add ASN1BitString class : not sure how to handle bitstring when unused bits is not zero

Add BIT_STRING_TYPE in asn1constants.dart

Modify ASN1Parser._doPrimitive to take BIT_STRING_TYPE into account

Modify asn1element_test.dart to test rsa public key

Changelog #

0.4.2 #

  • Added contentBytes() getter
  • Removed Int64List dependency and use bignum's BigInteger instead

0.4.3 #

  • Updates for dart 2

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  asn1lib: ^0.4.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:asn1lib/asn1lib.dart';
  
Version Uploaded Documentation Archive
0.5.8 Mar 28, 2019 Go to the documentation of asn1lib 0.5.8 Download asn1lib 0.5.8 archive
0.5.7 Mar 15, 2019 Go to the documentation of asn1lib 0.5.7 Download asn1lib 0.5.7 archive
0.5.6 Mar 15, 2019 Go to the documentation of asn1lib 0.5.6 Download asn1lib 0.5.6 archive
0.5.5 Mar 15, 2019 Go to the documentation of asn1lib 0.5.5 Download asn1lib 0.5.5 archive
0.5.4 Mar 14, 2019 Go to the documentation of asn1lib 0.5.4 Download asn1lib 0.5.4 archive
0.5.3 Oct 6, 2018 Go to the documentation of asn1lib 0.5.3 Download asn1lib 0.5.3 archive
0.5.2 Jul 28, 2018 Go to the documentation of asn1lib 0.5.2 Download asn1lib 0.5.2 archive
0.5.1 Jul 9, 2018 Go to the documentation of asn1lib 0.5.1 Download asn1lib 0.5.1 archive
0.5.0 Jun 15, 2018 Go to the documentation of asn1lib 0.5.0 Download asn1lib 0.5.0 archive
0.4.3 Jun 4, 2018 Go to the documentation of asn1lib 0.4.3 Download asn1lib 0.4.3 archive

All 21 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
86
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.2.4 <2.0.0