asgard_http_interceptor 1.0.0
asgard_http_interceptor: ^1.0.0 copied to clipboard

Fork of http_interceptor with attachment support.

0
likes
65 / 110
pub points
39 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

CHANGELOG.md is empty.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 14 out of 125 API elements (11.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:asgard_http_interceptor/http_client_with_interceptor.dart that imports:
  • package:http/io_client.dart that imports:
  • package:http/src/io_streamed_response.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/http_client_with_interceptor.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/models/http_interceptor_exception.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.13.00.13.10.13.1
meta^1.3.01.3.01.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
http_parser-4.0.04.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

0
likes
65
pub points
39%
popularity

Fork of http_interceptor with attachment support.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

sunnykinger@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, http, meta

More

Packages that depend on asgard_http_interceptor