artemis_custom 2.1.4
artemis_custom: ^2.1.4 copied to clipboard

Build dart types from GraphQL schemas and queries (using Introspection Query).

0
likes
80/ 130
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 220 out of 235 API elements (93.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:artemis_custom/builder.dart that imports:
  • package:artemis_custom/generator/print_helpers.dart that imports:
  • package:dart_style/dart_style.dart that imports:
  • package:dart_style/src/exceptions.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/sdk.dart that imports:
  • package:analyzer/dart/ast/visitor.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/element/type_schema_elimination.dart that imports:
  • package:analyzer/src/dart/element/type_schema.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/summary2/lazy_ast.dart that imports:
  • package:analyzer/src/summary2/linked_unit_context.dart that imports:
  • package:analyzer/src/summary2/linked_bundle_context.dart that imports:
  • package:analyzer/src/summary2/linked_element_factory.dart that imports:
  • package:analyzer/src/dart/resolver/scope.dart that imports:
  • package:analyzer/src/dart/element/scope.dart that imports:
  • package:analyzer/src/context/source.dart that imports:
  • package:analyzer/src/workspace/package_build.dart that imports:
  • package:analyzer/src/workspace/workspace.dart that imports:
  • package:analyzer/src/workspace/bazel.dart that imports:
  • package:analyzer/src/summary/package_bundle_reader.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/generator/print_helpers.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build^1.1.41.6.22.1.1
build_config^0.4.00.4.71.0.0
code_builder^3.2.03.7.04.1.0
dart_style^1.3.31.3.122.2.0
equatable^1.0.11.2.62.0.3
glob^1.2.01.2.02.0.2
gql^0.12.00.12.40.13.0
gql_code_gen^0.1.50.1.50.1.5
gql_dedupe_link^1.0.81.0.92.0.0
gql_exec^0.2.00.2.50.3.0
gql_http_link^0.2.50.2.70.4.0
gql_link^0.2.20.2.30.4.0
http^0.12.0+20.12.20.13.4
json_annotation^3.0.03.1.14.4.0
meta^1.1.71.7.01.7.0
path^1.6.21.8.01.8.0
recase^2.0.12.0.14.0.0
source_gen^0.9.4+20.9.10+31.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.031.0.0
analyzer-0.41.22.8.0
async-2.8.22.8.2
built_collection-5.1.15.1.1
built_value-8.1.38.1.3
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.3.50.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-5.2.16.1.2
fixnum-1.0.01.0.0
http_parser-3.1.44.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.110.12.11
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
pub_semver-2.1.02.1.0
pubspec_parse-0.1.81.1.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 15 issues. Showing the first 2:

The constraint `^1.1.4` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

The constraint `^0.4.0` on build_config does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions build_config to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.