ark_dart_crypto 1.0.0

Ark Dart - Crypto #

A simple Cryptography Implementation in Dart for the Ark Blockchain.

Build Status Codecov Latest Version License: MIT

Documentation #

You can find installation instructions and detailed instructions on how to use this package at the dedicated documentation site.

Security #

If you discover a security vulnerability within this package, please send an e-mail to security@ark.io. All security vulnerabilities will be promptly addressed.

Credits #

License #

MIT © ArkEcosystem

Changelog #

All notable changes to this project will be documented in this file.

The format is based on Keep a Changelog and this project adheres to Semantic Versioning.

Unreleased #

1.0.0 - 2019-07-15

Added #

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ark_dart_crypto: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ark_dart_crypto/ark_dart_crypto.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:ark_dart_crypto/ark_dart_crypto.dart.

Health issues and suggestions

Document public APIs. (-1 points)

111 out of 111 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/transactions/transaction.dart. (-0.50 points)

Analysis of lib/src/transactions/transaction.dart reported 1 hint:

line 106 col 9: Use isNotEmpty instead of length

Fix lib/src/utils/signature.dart. (-0.50 points)

Analysis of lib/src/utils/signature.dart reported 1 hint:

line 205 col 25: DO use curly braces for all flow control structures.

Format lib/ark_dart_crypto.dart.

Run dartfmt to format lib/ark_dart_crypto.dart.

Fix additional 13 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/configuration/fee.dart (Run dartfmt to format lib/src/configuration/fee.dart.)
  • lib/src/configuration/network.dart (Run dartfmt to format lib/src/configuration/network.dart.)
  • lib/src/identities/address.dart (Run dartfmt to format lib/src/identities/address.dart.)
  • lib/src/identities/private_key.dart (Run dartfmt to format lib/src/identities/private_key.dart.)
  • lib/src/identities/wif.dart (Run dartfmt to format lib/src/identities/wif.dart.)
  • lib/src/networks/devnet.dart (Run dartfmt to format lib/src/networks/devnet.dart.)
  • lib/src/networks/mainnet.dart (Run dartfmt to format lib/src/networks/mainnet.dart.)
  • lib/src/networks/network.dart (Run dartfmt to format lib/src/networks/network.dart.)
  • lib/src/networks/testnet.dart (Run dartfmt to format lib/src/networks/testnet.dart.)
  • lib/src/transactions/builder.dart (Run dartfmt to format lib/src/transactions/builder.dart.)
  • lib/src/transactions/deserializer.dart (Run dartfmt to format lib/src/transactions/deserializer.dart.)
  • lib/src/transactions/serializer.dart (Run dartfmt to format lib/src/transactions/serializer.dart.)
  • lib/src/utils/buffer.dart (Run dartfmt to format lib/src/utils/buffer.dart.)

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/ArkEcosystem/dart-crypto was unreachable.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and ark_dart_crypto.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
bip32 ^1.0.5 1.0.5
bs58check ^1.0.1 1.0.1
convert ^2.1.1 2.1.1
crypto ^2.0.6 2.1.2
pointycastle ^1.0.1 1.0.1
Transitive dependencies
charcode 1.1.2
collection 1.14.12
hex 0.1.2
typed_data 1.1.6
Dev dependencies
test ^1.6.4
test_coverage ^0.3.0