aris_flutter_logger 1.0.0+1
aris_flutter_logger: ^1.0.0+1 copied to clipboard

An easy-to-use logging tool, supporting logging to console or file, supporting configuring according to your environment

0
likes
80/ 130
pub points
18%
popularity

We analyzed this package on Oct 26, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 76 out of 106 API elements (71.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:aris_flutter_logger/aris_flutter_logger.dart that imports:
  • package:aris_flutter_logger/aris_log_utils.dart that imports:
  • package:aris_flutter_logger/outputs/rotate_file_output.dart that imports:
  • package:aris_flutter_logger/outputs/file_output.dart that imports:
  • package:flustars/flustars.dart that imports:
  • package:flustars/src/directory_util.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

lib/aris_log_utils.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/aris_tag_logger.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flustars^0.3.30.3.32.0.1
flutterflutter0.0.00.0.0
logger^0.9.40.9.41.1.0
sprintf^5.0.05.0.06.0.0
synchronized^2.2.0+22.2.0+23.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
common_utils-2.0.22.0.2
convert-3.0.13.0.1
crypto-3.0.13.0.1
decimal-1.3.01.3.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
rational-1.2.11.2.1
shared_preferences-2.0.82.0.8
shared_preferences_linux-2.0.22.0.2
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.22.0.2
sky_engine-0.0.990.0.99
sp_util-1.0.22.0.3
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.3.3` on flustars does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flustars to update the constraint.

The constraint `^0.9.4` on logger does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
80
pub points
18%
popularity

Publisher

aris.org.cn

An easy-to-use logging tool, supporting logging to console or file, supporting configuring according to your environment

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flustars, flutter, logger, sprintf, synchronized

More

Packages that depend on aris_flutter_logger