arcore_flutter_plugin 0.1.0 copy "arcore_flutter_plugin: ^0.1.0" to clipboard
arcore_flutter_plugin: ^0.1.0 copied to clipboard

PlatformAndroid

Flutter plugin for ARCore SDK, Android platform to build new augmented reality experiences

293
likes
110/ 140
pub points
93%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

10 out of 140 API elements (7.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: arcore_flutter_plugin, arcore_flutter_plugin.ArCoreAugmentedImage, arcore_flutter_plugin.ArCoreAugmentedImage.centerPose, arcore_flutter_plugin.ArCoreAugmentedImage.extentX, arcore_flutter_plugin.ArCoreAugmentedImage.extentZ.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:arcore_flutter_plugin/arcore_flutter_plugin.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:arcore_flutter_plugin/arcore_flutter_plugin.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:arcore_flutter_plugin/arcore_flutter_plugin.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:arcore_flutter_plugin/arcore_flutter_plugin.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:arcore_flutter_plugin/arcore_flutter_plugin.dart that declares support for platforms: Android.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'true'.

lib/src/shape/arcore_shape.dart:12:32

   ╷
12 │         'materials': materials != null
   │                                ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/shape/arcore_shape.dart

INFO: The import of 'dart:typed_data' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/services.dart'.

lib/src/arcore_controller.dart:1:8

  ╷
1 │ import 'dart:typed_data';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/arcore_controller.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.3 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
meta ^1.3.0 1.11.0 1.12.0
vector_math ^2.1.0 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
sky_engine - 0.0.99 0.0.99

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

293
likes
110
pub points
93%
popularity

Publisher

verified publishergdifrancesco.dev

Flutter plugin for ARCore SDK, Android platform to build new augmented reality experiences

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, flutter, meta, vector_math

More

Packages that depend on arcore_flutter_plugin