arasu_orm 0.0.1-alpha-1
arasu_orm: ^0.0.1-alpha-1 copied to clipboard

A Dart ORM for arasu frameowrk

0
likes
75 / 110
pub points
0 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://arasuframework.org/ was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:13:49

   ╷
13 │ <p>Please file feature requests and bugs at the <a href="http://example.com/issues/replaceme">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/arasu_orm_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 9 API elements (22.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/arasu_orm_base.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/c0.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular^6.0.16.0.16.0.1
angular_test^3.0.03.0.03.0.0
logging^0.11.40.11.41.0.1
path^1.7.01.8.01.8.0
test^1.15.41.16.51.16.8
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.020.0.0
analyzer-0.40.61.4.0
angular_ast-1.0.11.0.1
angular_compiler-1.0.11.0.1
args-1.6.02.0.0
async-2.5.02.5.0
boolean_selector-2.1.02.1.0
build-1.6.22.0.0
build_config-0.4.70.4.7
built_collection-5.0.05.0.0
built_value-8.0.48.0.4
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.0
code_builder-3.7.03.7.0
collection-1.15.01.15.0
convert-2.1.13.0.0
coverage-0.15.21.0.2
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dart_style-1.3.102.0.0
file-5.2.16.1.0
fixnum-1.0.01.0.0
glob-1.2.02.0.1
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
intl-0.16.10.17.0
io-1.0.01.0.0
js-0.6.30.6.3
json_annotation-4.0.14.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-1.0.01.0.0
node_interop-1.2.12.0.0
node_io-1.2.01.2.0
node_preamble-1.4.132.0.0
package_config-1.9.32.0.0
pool-1.5.01.5.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
shelf-1.1.01.1.0
shelf_packages_handler-2.0.13.0.0
shelf_static-0.2.9+21.0.0
shelf_web_socket-0.2.4+11.0.1
source_gen-0.9.10+21.0.0
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.2.190.3.0
test_core-0.3.150.3.19
typed_data-1.3.01.3.0
vm_service-6.2.06.2.0
watcher-0.9.7+151.0.0
web_socket_channel-1.2.02.0.0
webkit_inspection_protocol-0.7.51.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.11.4` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
75
pub points
0%
popularity

A Dart ORM for arasu frameowrk

Homepage

Documentation

API reference

Uploader

arasuresearch@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

angular, angular_test, logging, path, test

More

Packages that depend on arasu_orm