aqueduct_test 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 88

Test framework for aqueduct applications. This package is included as a dev_dependency of aqueduct applications.

The documentation for this package is available at https://aqueduct.io/docs/testing/.

1.0.1 #

  • Fixes analysis warnings for Dart 2.1.1

1.0.0+1 #

  • Bumps some dependency constraints to be more permissive

1.0.0 #

  • Initial version from package:aqueduct.
  • Adds TestHarness base class for test harnesses.
  • Adds TestHarnessORMMixin for testing ORM applications.
  • Adds TestHarnessAuthMixin for testing OAuth2 applications.
  • Renames TestClient to Agent and adds methods for executing requests without constructing a TestRequest.
  • Adds default parameters to Agent for its requests.

example/main.dart

import 'package:aqueduct_test/aqueduct_test.dart';
import 'package:aqueduct/aqueduct.dart';
import 'package:test/test.dart';

void main() {
  final harness = TestHarness<App>()..install();

  test("GET /example returns simple map", () async {
    final response = await harness.agent.get("/example");
    expectResponse(response, 200, body: {"key": "value"});
  });
}

class App extends ApplicationChannel {
  @override
  Controller get entryPoint {
    final router = Router();
    router.route("/example").linkFunction((req) async => Response.ok({"key": "value"}));
    return router;
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aqueduct_test: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aqueduct_test/aqueduct_test.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
78
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95
Overall:
Weighted score of the above. [more]
88
Learn more about scoring.

We analyzed this package on Mar 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health suggestions

Format lib/src/auth_harness.dart.

Run dartfmt to format lib/src/auth_harness.dart.

Maintenance suggestions

Package is getting outdated. (-5.48 points)

The package was last published 55 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
aqueduct ^3.0.0 3.2.1
matcher >=0.12.3 <0.14.0 0.12.5 0.12.6
test ^1.3.0 1.6.3 1.14.2
Transitive dependencies
analyzer 0.35.4 0.39.4
args 1.6.0
async 2.4.1
boolean_selector 1.0.5 2.0.0
charcode 1.1.3
codable 1.0.0
collection 1.14.12
convert 2.1.1
crypto 2.1.4
front_end 0.1.14 0.1.29
glob 1.2.0
http 0.12.0+4
http_multi_server 2.2.0
http_parser 3.1.4
io 0.3.3
isolate_executor 2.0.2+3
js 0.6.1+1
json_rpc_2 2.1.0
kernel 0.3.14 0.3.29
logging 0.11.4
meta 1.1.8
mime 0.9.6+3
multi_server_socket 1.0.2
node_interop 1.0.3
node_io 1.0.1+2
node_preamble 1.4.8
open_api 2.0.1
package_config 1.9.3
package_resolver 1.0.10
password_hash 2.0.0
path 1.6.4
pedantic 1.9.0
pool 1.4.0
postgres 1.0.2 2.1.0
pub_cache 0.2.3
pub_semver 1.4.4
safe_config 2.0.2 3.0.0-b2
shelf 0.7.5
shelf_packages_handler 1.0.4 2.0.0
shelf_static 0.2.8
shelf_web_socket 0.2.3
source_map_stack_trace 1.1.5 2.0.0
source_maps 0.10.9
source_span 1.7.0
stack_trace 1.9.3
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.5 0.2.15
test_core 0.2.5 0.3.3
typed_data 1.1.6
vm_service_client 0.2.6+3
watcher 0.9.7+14
web_socket_channel 1.1.0
yaml 2.2.0