appsize 1.2.1 copy "appsize: ^1.2.1" to clipboard
appsize: ^1.2.1 copied to clipboard

A Flutter package for Easily make Flutter apps responsive. Automatically adapt UI to different screen sizes. Responsiveness made simple.

11
likes
150/ 160
pub points
70%
popularity

We analyzed this package 2 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

25 out of 27 API elements (92.6 %) have documentation comments.

Some symbols that are missing documentation: appsize, appsize.AppSize.AppSize.child.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:appsize/appsize.dart that imports:
  • package:universal_io/io.dart that imports:
  • package:universal_io/src/_exports_in_browser.dart that imports:
  • package:universal_io/src/internet_address.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/extension.dart:1:1

  ╷
1 │ part of appsize;
  │ ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/extension.dart

INFO: The part-of directive uses a library name.

lib/util.dart:1:1

  ╷
1 │ part of appsize;
  │ ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/util.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
universal_io ^2.0.4 2.2.2 2.2.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

11
likes
150
pub points
70%
popularity

Publisher

verified publishermibus-app.com.ar

A Flutter package for Easily make Flutter apps responsive. Automatically adapt UI to different screen sizes. Responsiveness made simple.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

flutter, universal_io

More

Packages that depend on appsize