apple_sign_in 0.0.1

Apple Sign In - Flutter Plugin #

Access Sign In with Apple from Flutter.

⚠️ This plugin is still in development and APIs will probably still change ⚠️

Platform support #

This plugin currently only supports iOS. There's a JavaScript framework for Android.

To Do #

  • Documentation
  • Support for revocation notifications
  • Support for iOS 12 and below, including an isAvailable() method to check if sign in is available
  • Flutter widget version of the "Sign in With Apple" button, to avoid the cost of creating a UIKit view

Implementing #

  1. Configure your app in Xcode to add the "Sign In with Apple" capability
  2. Enable Flutter platform views: in your app's Info.plist, add a boolean field with the key io.flutter.embedded_views_preview with the value YES
  3. See the example app to see how the API works

0.0.1 #

  • TODO: Describe initial release.

example/README.md

apple_sign_in_example #

Demonstrates how to use the apple_sign_in plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  apple_sign_in: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:apple_sign_in/apple_sign_in.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
50
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Aug 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/apple_id_button.dart.

Run flutter format to format lib/apple_id_button.dart.

Format lib/apple_id_credential.dart.

Run flutter format to format lib/apple_id_credential.dart.

Format lib/apple_id_request.dart.

Run flutter format to format lib/apple_id_request.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/apple_sign_in.dart (Run flutter format to format lib/apple_sign_in.dart.)
  • lib/authorization_scope.dart (Run flutter format to format lib/authorization_scope.dart.)
  • lib/open_id_operation.dart (Run flutter format to format lib/open_id_operation.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (meta).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
flutter 0.0.0
meta ^1.1.6 1.1.6 1.1.7
Transitive dependencies
collection 1.14.11 1.14.12
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test