app_installer 1.1.0 copy "app_installer: ^1.1.0" to clipboard
app_installer: ^1.1.0 copied to clipboard

A new Android + iOS app installer plugin , supports opening app stores and editor reviews, as well as installing Apk files.

63
likes
150/ 160
pub points
94%
popularity

We analyzed this package 6 days ago, and awarded it 150 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: app_installer,
    • contains a version property, and,
    • does not contain a publish_to property.

pubspec.yaml from the repository defines publish_to, thus, we are unable to verify the package is published from here.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 5 API elements (40.0 %) have documentation comments.

Some symbols that are missing documentation: app_installer, app_installer.AppInstaller, app_installer.AppInstaller.AppInstaller.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:app_installer/app_installer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:app_installer/app_installer.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:app_installer/app_installer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:app_installer/app_installer.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

63
likes
150
pub points
94%
popularity

Publisher

unverified uploader

A new Android + iOS app installer plugin , supports opening app stores and editor reviews, as well as installing Apk files.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

Apache-2.0 (license)

Dependencies

flutter

More

Packages that depend on app_installer