app_forms 0.5.0 copy "app_forms: ^0.5.0" to clipboard
app_forms: ^0.5.0 copied to clipboard

App Forms Separate the logic from the user interface by use flutter_form_builder

8
likes
120/ 140
pub points
4%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

305 out of 575 API elements (53.0 %) have documentation comments.

Some symbols that are missing documentation: app_forms, app_forms.AppForm, app_forms.AppForm.AppForm, app_forms.AppForm.autoValidate, app_forms.AppForm.formKey.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: AppFormListener.setState

lib/src/widgets/app_form_listener.dart:6:7

  ╷
6 │ class AppFormListener<T extends AppForm> extends StatelessWidget {
  │       ^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/app_form_listener.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_form_builder ^9.2.1 9.3.0 9.3.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
intl - 0.19.0 0.19.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

8
likes
120
pub points
4%
popularity

Publisher

verified publisherm-it.dev

App Forms Separate the logic from the user interface by use flutter_form_builder

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_form_builder

More

Packages that depend on app_forms