apns_flutter 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 66

Apns Flutter #

Use Flutter to interact with the native push notifications system on iOS.

Requires iOS 10 or later

Example #

final apns = ApnsFlutter();
apns.onToken((token) {
  print(token);
});
apns.onSettings((settings) {
  print(settings);
});
apns.register(badge: true, alert: true, sound: true);

0.0.2 #

  • Set and get the badge number.
  • Get current notifications from center.
  • Delete notifications from center.
  • See what notification caused the app to open.

0.0.1 #

  • Implement basic functionality.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:apns_flutter/apns_flutter.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  final apns = ApnsFlutter();

  String token;

  void register() async {
    apns.onToken((token) {
      setState(() {
        this.token = token;
      });
    });
    apns.register(badge: true, alert: true, sound: true);
  }

  @override
  Widget build(BuildContext context) {
    if (token == null) {
      return MaterialApp(
        home: Scaffold(
          appBar: AppBar(
            title: const Text('Flutter APNS Example'),
            actions: <Widget>[
              FlatButton(
                child: Text("Get Token"),
                onPressed: () {
                  register();
                },
              ),
            ],
          ),
          body: Center(
            child: Text("Token not received.", style: TextStyle(fontSize: 20)),
          ),
        ),
      );
    } else {
      return MaterialApp(
        home: Scaffold(
          appBar: AppBar(
            title: const Text('Flutter APNS Example'),
          ),
          body: Center(
            child: Text(token, style: TextStyle(fontSize: 20)),
          ),
        ),
      );
    }
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  apns_flutter: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:apns_flutter/apns_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:apns_flutter/apns_flutter.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:apns_flutter/apns_flutter.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:apns_flutter/apns_flutter.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:apns_flutter/apns_flutter.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • apns_flutter that is a package requiring null.

Health suggestions

Format lib/apns_flutter.dart.

Run flutter format to format lib/apns_flutter.dart.

Format lib/models/notification.dart.

Run flutter format to format lib/models/notification.dart.

Format lib/models/settings.dart.

Run flutter format to format lib/models/settings.dart.

Format lib/src/apnsflutter.dart.

Run flutter format to format lib/src/apnsflutter.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test