apivideo_player 1.3.0 copy "apivideo_player: ^1.3.0" to clipboard
apivideo_player: ^1.3.0 copied to clipboard

The official Flutter player for api.video for iOS, Android and Web.

19
likes
140/ 140
pub points
80%
popularity

We analyzed this package 10 hours ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/apivideo/api.video-flutter-player/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

113 out of 202 API elements (55.9 %) have documentation comments.

Some symbols that are missing documentation: apivideo_player, apivideo_player.ApiVideoMobilePlayer.getPlaybackRate, apivideo_player.ApiVideoMobilePlayer.setPlaybackRate, apivideo_player.ApiVideoPlayerController, apivideo_player.ApiVideoPlayerController.kUninitializedTextureId.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:apivideo_player/apivideo_player.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:apivideo_player/apivideo_player.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:apivideo_player/apivideo_player.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:apivideo_player/apivideo_player.dart that imports:
  • package:apivideo_player/src/widgets/apivideo_player_overlay.dart that imports:
  • package:pointer_interceptor/pointer_interceptor.dart that declares support for platforms: iOS, Web.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
js ^0.7.0 0.7.1 0.7.1
json_annotation ^4.8.1 4.9.0 4.9.0
meta ^1.9.1 1.12.0 1.15.0
plugin_platform_interface ^2.1.5 2.1.8 2.1.8
pointer_interceptor ^0.10.1 0.10.1+1 0.10.1+1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
pointer_interceptor_ios - 0.10.1 0.10.1
pointer_interceptor_platform_interface - 0.10.0+1 0.10.0+1
pointer_interceptor_web - 0.10.2 0.10.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.