apivideo_live_stream 1.2.0 copy "apivideo_live_stream: ^1.2.0" to clipboard
apivideo_live_stream: ^1.2.0 copied to clipboard

Flutter RTMP live stream client for your audio/video application. Made with ♥ by api.video.

79
likes
130/ 140
pub points
90%
popularity

We analyzed this package 40 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

68 out of 97 API elements (70.1 %) have documentation comments.

Some symbols that are missing documentation: apivideo_live_stream, apivideo_live_stream.ApiVideoLiveStreamController.addEventsListener, apivideo_live_stream.ApiVideoLiveStreamController.ApiVideoLiveStreamController.fromListener, apivideo_live_stream.ApiVideoLiveStreamController.kUninitializedTextureId, apivideo_live_stream.ApiVideoLiveStreamController.removeEventsListener.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:apivideo_live_stream/apivideo_live_stream.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:apivideo_live_stream/apivideo_live_stream.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:apivideo_live_stream/apivideo_live_stream.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:apivideo_live_stream/apivideo_live_stream.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
json_annotation ^4.8.1 4.9.0 4.9.0
meta ^1.9.0 1.12.0 1.15.0
native_device_orientation ^1.2.1 1.2.1 2.0.3
plugin_platform_interface ^2.1.6 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.2.1` on native_device_orientation does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions native_device_orientation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

79
likes
130
pub points
90%
popularity

Publisher

verified publisherapi.video

Flutter RTMP live stream client for your audio/video application. Made with ♥ by api.video.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, json_annotation, meta, native_device_orientation, plugin_platform_interface

More

Packages that depend on apivideo_live_stream