apco_utils 0.0.2 icon indicating copy to clipboard operation
apco_utils: ^0.0.2 copied to clipboard

Andishe Pardaz Utilities to formating and converting date for Flutter

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
10 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/iranandishepardaz/apco_utils was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 11 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:apco_utils/apco_utils.dart that declares support for platforms: Android, iOS.

Package does not support platform Linux.

Because:

  • package:apco_utils/apco_utils.dart that declares support for platforms: Android, iOS.

Package does not support platform macOS.

Because:

  • package:apco_utils/apco_utils.dart that declares support for platforms: Android, iOS.

Package does not support platform Web.

Because:

  • package:apco_utils/apco_utils.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.20, Flutter 3.3.7, Dart 2.18.4.

0
likes
90
pub points
0%
popularity

Publisher

unverified uploader

Andishe Pardaz Utilities to formating and converting date for Flutter

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on apco_utils