ansi_up 1.0.0 copy "ansi_up: ^1.0.0" to clipboard
ansi_up: ^1.0.0 copied to clipboard

Minimal package containing 'ansi_up' third_party dependency used by package:devtools.

1
likes
125/ 160
pub points
93%
popularity

We analyzed this package 3 days ago, and awarded it 125 pub points (of a possible 160):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:3:1

  ╷
3 │ <a href="http://en.wikipedia.org/wiki/ANSI_escape_code#Colors">ANSI color escape codes</a> into HTML.</p>
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

4 out of 22 API elements (18.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: ansi_up, ansi_up.AnsiUp.ansiColors, ansi_up.AnsiUp.bg, ansi_up.AnsiUp.bold, ansi_up.AnsiUp.fg.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/ansi_up.dart:5:1

  ╷
5 │ ┌ /// ansi_up is an library that parses text containing ANSI color escape
6 │ └ /// codes.
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/ansi_up.dart

INFO: A value for optional parameter 'text' isn't ever given.

lib/ansi_up.dart:307:41

    ╷
307 │   _TextPacket({required this.kind, this.text = '', this.url = ''});
    │                                         ^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/ansi_up.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

1
likes
125
pub points
93%
popularity

Publisher

unverified uploader

Minimal package containing 'ansi_up' third_party dependency used by package:devtools.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (license)

More

Packages that depend on ansi_up